Skip to main content

Que faut-il pour exploiter pleinement Workflow Foundation ?

Aujourd'hui, si l'on souhaite coder/exécuter du Workflow Foundation il faut :

  • Pour développer : Visual Studio 2010 (le minima pour WF 4.0) ou ses versions ultérieures pour exploiter WF 4.5.
  • Pour exécuter : .net Framework complet (la version client apparue avec .net 4.0 n'est pas utilisable).
  • Pour utiliser la persistance : .net 4, mais 4.5 est plus approprié, car il apporte quelques simplifications et optimisations. SQL Server 2005 SP4 à minima (2012 et 2014 sont supporté). SQL Express est supporté (très pratique pour un environnement de développement, mais déconseillé pour la production pour ne pas limiter la montée en charge).
  • Pour utiliser le versioning : .net 4.5.
  • Pour IIS : IIS7 et des pools en mode full trust.

Ce ne sont que les minimas. Évidemment, un Visual Studio 2015 est plus appréciable pour coder ;)

Le support de .net 4.0 et 4.5 prenant fin en janvier, il est évidemment plus prudent d'utiliser .net 4.5.2. – SQL Server 2005 arrivant aussi en fin de vie, une version plus récente est préférable (ex : SQL Server 2012).

Jérémy Jeanson

Comments

You have to be logged in to comment this post.

Cookies Cookie Policy

This website uses cookies and similar technologies to allow us to promote our services and enhance your browsing experience. If you continue to use this website you agree to our use of cookies.